Autor Thema: Befehl "make install" ?  (Gelesen 8893 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Nawuko

  • Foren-Aktivist
  • **
  • Beiträge: 26
  • Geschlecht: Männlich
  • Bis jetzt ein Nichtsk?nner
  • Betriebssystem: OpenSuse11.2
  • Grafische Oberfläche: KDE
  • Hardware: Thinkpad SL510
Befehl "make install" ?
« am: 24.Februar 2010, 22:23:30 »
Hi jungs,

Ich hab mal wieder ein problem, jedoch m?chte ich vorher was zu meinem stand sagen: Danke das ihr mir so viel und so schnell geholfen habt ich bin jetzt echt super zufrieden mit suse und m?chte nichts anderres mehr haben.. total toll danke daf?r.

Nun zu meinem Prob.:

Ich m?chte einen bestimmten treiber installieren f?r meinen Wlan-Adapter damit der einen bestimmten modus unterst?tzt.

wget http://homepages.tu-darmstadt.de/~p_larbig/wlan/rt73-k2wrlz-3.0.3.tar.bz2
tar -xjf rt73-k2wrlz-3.0.3.tar.bz2
cd rt73-k2wrlz-3.0.3/Module
make
make install
modprobe rt73

bis "cd rt73-k2wrlz-3.0.3/Module" ging alles ohne weiterre probleme
aber anscheinend gibt es den befehl "make" bei Suse nicht gibt es da einen anderren befehl f?r? ich glaube "make install" kennt suse auch nicht.
Was k?nnte man da machen ?

vielen dank

Nawu.

EDIT: Bei "make" kommt diese meldung;
make: *** /lib/modules/2.6.31.12-0.1-desktop/build: No such file or directory.  Stop.
rt73.ko failed to build!
make: *** [module] Error 1

bei "make install" make install!!! rt73.ko does not exist: run 'make'
make: *** [modules_install] Error 1


also suse kennt wohl doch den befehl verstehe aber die fehlermeldung nicht soo ganz... soweit bin ich dann doch noch nicht
« Letzte Änderung: 24.Februar 2010, 22:27:39 von Nawuko »
Wer glaubt etwas zu sein hat aufgeh?rt etwas zu werden.

Offline Skipper

  • Foren-Gott
  • *******
  • Beiträge: 2182
  • Geschlecht: Männlich
  • Sic volo, sic iubeo!
  • Betriebssystem: GENTOO+Ubuntu
  • Grafische Oberfläche: UNITY-GNOME-XFCE
  • Hardware: ASUS Sabertooth 990 FX R2.0, FX 8150, 2xNV GTX 660, 16 GB Corsair, Cougar 1050, Enermax ETS-T40-TA, Sharkoon T9
Antw:Befehl "make install" ?
« Antwort #1 am: 25.Februar 2010, 11:45:33 »
Hey,

sei mir bitte nicht b?se, aber aus meiner Sicht ist es nicht in Ordnung, wenn Du das installieren willst! Ich habe die mods informiert.

Die Rechtsprechung in Deutschland ist noch nicht ganz klar, wie viel derjenige zu verantworten hat, der Wlan zur Verf?gung stellt ...

M?chten die Mods und Admins entscheiden und meinen Beitrag ggf. wieder l?schen ....



Skipper
Wer fragt, ist ein Narr für fünf Minuten. Wer nicht fragt, bleibt für immer ein Narr! (Chinesisches Sprichwort )

Offline Nawuko

  • Foren-Aktivist
  • **
  • Beiträge: 26
  • Geschlecht: Männlich
  • Bis jetzt ein Nichtsk?nner
  • Betriebssystem: OpenSuse11.2
  • Grafische Oberfläche: KDE
  • Hardware: Thinkpad SL510
Antw:Befehl "make install" ?
« Antwort #2 am: 25.Februar 2010, 12:57:13 »
 [rofl] ich frag mich was daran so schlimm ist wenn mein die sicherheit seines eigenen netzes ?bepr?fen will naja ^^ informier die ruhig..  [ironie]
Wer glaubt etwas zu sein hat aufgeh?rt etwas zu werden.

Offline Old Man

  • Foren-Gott
  • *******
  • Beiträge: 5585
Antw:Befehl "make install" ?
« Antwort #3 am: 25.Februar 2010, 14:01:24 »
Hi Nawuko

Ich habe mir das ganze mal angeschaut. Das ist alles rechtens. Mach Dir diesbez?glich keine Sorgen.

Ferner habe ich f?r Dein Problem ein Howto gefunden.
http://www.computer-labs.de/tutorials.php?Kategorie=Linux&id=72

Es k?nnte zwar ein anderes WLAN Ger?t sein, was Du benutzt, aber das sollte nicht das Problem sein.


Ralf

Offline Linuxtal

  • Administrator
  • Foren-König
  • *******
  • Beiträge: 934
  • Geschlecht: Männlich
  • Linux Extrem Benutzer
    • Home of Linuxtal
  • Betriebssystem: Arch Linux
  • Grafische Oberfläche: Gnome 3 und Mate gemischt
  • Hardware: Packard Bell - Intel i920 - 16 GB RAM - NVIDIA GT250 Dualscreen
Antw:Befehl "make install" ?
« Antwort #4 am: 25.Februar 2010, 14:04:26 »
Hallo,

@Ralle

ist das nicht ein L?sungsweg f?r Debian bzw. Ubuntu?

Es geht hier aber um SuSE so weit ich es verstanden habe.

Habe gerade auch eine PN an Skipper gesendet deswegen

m.f.g.
Carl-Heinz
## Gott sei dank,ich bin weg vom Fenster ##

Offline Nawuko

  • Foren-Aktivist
  • **
  • Beiträge: 26
  • Geschlecht: Männlich
  • Bis jetzt ein Nichtsk?nner
  • Betriebssystem: OpenSuse11.2
  • Grafische Oberfläche: KDE
  • Hardware: Thinkpad SL510
Antw:Befehl "make install" ?
« Antwort #5 am: 25.Februar 2010, 14:07:32 »
HI danke ralle, ich werde mir das tutorial mal angucken. ich m?chte hier nochmals betonen das ich NICHTS Illegales vorhabe und mich lediglich vor angriffen sch?tzen m?chte. Ich bin ein Mensch der gerne selber testet anstatt nur zu h?ren ist sicher, weil in einem Ernstfall muss ich haften.

EDIT: Im allgemeinen geht der Befehl "make" nicht, habt ihr denn dort eine l?sung f?r? Es kann ja sein das man so einen Befehl auch ?fter mal braucht.

Vielen dank

Nawu
« Letzte Änderung: 25.Februar 2010, 14:11:12 von Nawuko »
Wer glaubt etwas zu sein hat aufgeh?rt etwas zu werden.

Offline Old Man

  • Foren-Gott
  • *******
  • Beiträge: 5585
Antw:Befehl "make install" ?
« Antwort #6 am: 25.Februar 2010, 14:07:53 »
Hi

Stimmt, er hat ja SuSE.
Ich habe garnicht daran gedacht, das sowas noch jemand benutzt [groehl]

Dann schau ich doch noch mal, ob ich was anderes finde.

Offline Old Man

  • Foren-Gott
  • *******
  • Beiträge: 5585
Antw:Befehl "make install" ?
« Antwort #7 am: 25.Februar 2010, 14:19:11 »
Warum nimmst Du denn nicht die Treiber von SuSE?
http://software.opensuse.org/search

Einfach rt73 eingeben und Du hast die freie Auswahl.

Ralf

Offline Linuxtal

  • Administrator
  • Foren-König
  • *******
  • Beiträge: 934
  • Geschlecht: Männlich
  • Linux Extrem Benutzer
    • Home of Linuxtal
  • Betriebssystem: Arch Linux
  • Grafische Oberfläche: Gnome 3 und Mate gemischt
  • Hardware: Packard Bell - Intel i920 - 16 GB RAM - NVIDIA GT250 Dualscreen
Antw:Befehl "make install" ?
« Antwort #8 am: 25.Februar 2010, 16:10:19 »
Hallo,

ich kenne mich auch nicht mit SuSE aus, aber unter Ubuntu muss ich das erst installieren und auch noch einen C-Compiler.

Wo sind denn die SuSE Kompilierer die werden ja wissen was man unter SuSE braucht um es zu kompilieren.  :kiss:

m.f.g.
Carl-Heinz
## Gott sei dank,ich bin weg vom Fenster ##

Offline Nawuko

  • Foren-Aktivist
  • **
  • Beiträge: 26
  • Geschlecht: Männlich
  • Bis jetzt ein Nichtsk?nner
  • Betriebssystem: OpenSuse11.2
  • Grafische Oberfläche: KDE
  • Hardware: Thinkpad SL510
Antw:Befehl "make install" ?
« Antwort #9 am: 25.Februar 2010, 16:16:23 »
oh mein gott ich bin so oberd?mlich danke ralle..
Wieso
Zitat
Ich habe garnicht daran gedacht, das sowas noch jemand benutzt [groehl]
Gibt es da viel besseres?

Gru?

Nawu.
Wer glaubt etwas zu sein hat aufgeh?rt etwas zu werden.

Offline Old Man

  • Foren-Gott
  • *******
  • Beiträge: 5585
Antw:Befehl "make install" ?
« Antwort #10 am: 25.Februar 2010, 16:26:47 »
Zitat
Gibt es da viel besseres?

Na klar. z.B. Gentoo
Bevor Du aber jetzt weiter ?berlegst. Gentoo ist nichts f?r Anf?nger.
Lerne erst mal mit SuSE und dann kann man sp?ter immer noch wechseln.

Sehe erst mal zu das Du den Treiber installiert bekommst.

Offline Linuxtal

  • Administrator
  • Foren-König
  • *******
  • Beiträge: 934
  • Geschlecht: Männlich
  • Linux Extrem Benutzer
    • Home of Linuxtal
  • Betriebssystem: Arch Linux
  • Grafische Oberfläche: Gnome 3 und Mate gemischt
  • Hardware: Packard Bell - Intel i920 - 16 GB RAM - NVIDIA GT250 Dualscreen
Antw:Befehl "make install" ?
« Antwort #11 am: 25.Februar 2010, 16:37:42 »
Hallo,

hast du einen C Compiler installiert?

Zitat
gcc --version

sagt dir da mehr.

m.f.g.
Carl-Heinz
## Gott sei dank,ich bin weg vom Fenster ##

Offline Nawuko

  • Foren-Aktivist
  • **
  • Beiträge: 26
  • Geschlecht: Männlich
  • Bis jetzt ein Nichtsk?nner
  • Betriebssystem: OpenSuse11.2
  • Grafische Oberfläche: KDE
  • Hardware: Thinkpad SL510
Antw:Befehl "make install" ?
« Antwort #12 am: 25.Februar 2010, 17:10:34 »
Genau deswegen hatte ich auch SuSe genommen weil es Anf?nger freundlich ist.
hatte gedacht es gibt bessere Anf?nger Freundliche Discributionen..

Na klasse xD Der treiber ist nun drauf xD Sobalt ich auf das Netzwerksymbol ich anklicke und ?ber den Stick mit der maus fahre (siehe anhang) sagt er mir "Treiber: rt73usb" jedoch wird der Monitormode immer noch nicht unterst?tzt.

gcc --version gibt es wohl nicht (siehe anhang)
Welchen davon soll ich installieren?

EDIT: Bitte nicht die Bilder von Fremden Servern hierher verlinken. Du kannst Bilder an jeden Beitrag anh?ngen!!!
« Letzte Änderung: 26.Februar 2010, 08:50:27 von bloedie »
Wer glaubt etwas zu sein hat aufgeh?rt etwas zu werden.

Offline Linuxtal

  • Administrator
  • Foren-König
  • *******
  • Beiträge: 934
  • Geschlecht: Männlich
  • Linux Extrem Benutzer
    • Home of Linuxtal
  • Betriebssystem: Arch Linux
  • Grafische Oberfläche: Gnome 3 und Mate gemischt
  • Hardware: Packard Bell - Intel i920 - 16 GB RAM - NVIDIA GT250 Dualscreen
Antw:Befehl "make install" ?
« Antwort #13 am: 25.Februar 2010, 17:35:01 »
Hallo,

dann musst du wohl noch den gcc Compiler installieren.

m.f.g.
Carl-Heinz
## Gott sei dank,ich bin weg vom Fenster ##

Offline tuxusmaximus

  • Administrator
  • Foren-Gott
  • *****
  • Beiträge: 2352
  • Geschlecht: Männlich
  • Betriebssystem: Debian 8.10
  • Grafische Oberfläche: KDE, Gnome
  • Hardware: Lenovo T400, Intel Core2Duo P8600 2x 2,4 GHz, 8 GB, Intel Media Accelerator 400 MHD, "640 GB" Hdd, Epson WorkForce Pro WP-4525 DNF
Antw:Befehl "make install" ?
« Antwort #14 am: 25.Februar 2010, 17:58:59 »
Hi Nawuko,

eine bitte: Bilder bitte nicht bei externen Anbietern ablegen. Dies kannst du hier auch sehr einfach tun. Einfach im Feld "Datei anh?ngen" ausw?hlen. Beim "Schreiben" werden diese dann automatisch hochgeladen.
Gruß Tuxus

Und aus dem Chaos sprach eine Stimme zu mir:
"Lächle und sei froh, es könnte schlimmer kommen!"
Und ich lächelte und war froh, und es kam schlimmer!