Autor Thema: Yast will nicht mehr  (Gelesen 7163 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline goldenstar

  • Foren-Aktivist
  • **
  • Beiträge: 11
Yast will nicht mehr
« am: 27.September 2009, 16:50:49 »
Hi,

ich bekomme bei Yast eine Fehlermeldung wenn ich im Yast etwas ausw?hle.
Hier die Meldung:

terminate called after throwing an instance of 'YUIPluginException'
  what():  Couldn't load plug-in qt
YaST got signal 6 at YCP file Wizard.ycp:688
/sbin/yast2: line 421: 12177 Abgebrochen             $ybindir/y2base $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS



wer kann mir da einen guten Tipp geben.

mfg Goldenstar

Offline Zickenbaendiger

  • Global Moderator
  • Foren-Gott
  • *****
  • Beiträge: 3867
  • Geschlecht: Männlich
  • Ich hab nen knochenharten Job
  • Betriebssystem: Gentoo ten | Debian Squeeze | Debian Squeeze 6.0.3
  • Grafische Oberfläche: KDE 4.6.0 | KDE 4.4.5 | Enlightment 16 + 17
  • Hardware: 1 GB Ram, Grafikkarte Nvidia Geforce 8400 GS, Drucker HP 990 cxi, Scanner Canon D660U, Soundkarte Soundblaster Live, 3 SATA Platten 2 Stck. a 160 GB 1 x 250 GB + 1 80 GB
Re: Yast will nicht mehr
« Antwort #1 am: 27.September 2009, 16:59:14 »
Hi,

Zitat
Couldn't load plug-in qt
Die Fehlermeldung steht hier beschrieben, er kann das Modul qt nicht laden oder finden.
Also installiere es doch einfach mal neu.
Wenn du Yast nicht mehr im Grafischen Modus starten kannst, dann mache es doch auf der Shell.
Einfach als root anmelden und dann Yast eingeben, dann wie gewohnt bei Software das qt Paket ausw?hlen und installieren lassen.
Danach erneut probieren.


Gru? Zicke
AIRIS Laptop, Intel Pentium Dual-Core T3200 2.00GHz, Gentoo Ten

Offline goldenstar

  • Foren-Aktivist
  • **
  • Beiträge: 11
Re: Yast will nicht mehr
« Antwort #2 am: 27.September 2009, 20:29:56 »
Hi,

ich habe alle Yast-Pakete neu installiert und bekomme die Fehlermeldung immer noch.

Gru? Goldenstar

Offline Zickenbaendiger

  • Global Moderator
  • Foren-Gott
  • *****
  • Beiträge: 3867
  • Geschlecht: Männlich
  • Ich hab nen knochenharten Job
  • Betriebssystem: Gentoo ten | Debian Squeeze | Debian Squeeze 6.0.3
  • Grafische Oberfläche: KDE 4.6.0 | KDE 4.4.5 | Enlightment 16 + 17
  • Hardware: 1 GB Ram, Grafikkarte Nvidia Geforce 8400 GS, Drucker HP 990 cxi, Scanner Canon D660U, Soundkarte Soundblaster Live, 3 SATA Platten 2 Stck. a 160 GB 1 x 250 GB + 1 80 GB
Re: Yast will nicht mehr
« Antwort #3 am: 27.September 2009, 20:36:17 »
Hi,

welche suse Version hast du denn, starte doch mal deinen Rechner neu.
Wenn das immer noch nicht hilft, dann leg mal die Installations CD/DVD ins Laufwerk und starte den Rechner ebenfalls neu,
im erscheinenden Men? gehst du auf Wiederherstellen oder reparieren.
Dann wird Suse versuchen alle defekten Pakete zu reparieren.


Gru? Zicke
AIRIS Laptop, Intel Pentium Dual-Core T3200 2.00GHz, Gentoo Ten

Offline tuxusmaximus

  • Administrator
  • Foren-Gott
  • *****
  • Beiträge: 2353
  • Geschlecht: Männlich
  • Betriebssystem: Debian 8.10
  • Grafische Oberfläche: KDE, Gnome
  • Hardware: Lenovo T400, Intel Core2Duo P8600 2x 2,4 GHz, 8 GB, Intel Media Accelerator 400 MHD, "640 GB" Hdd, Epson WorkForce Pro WP-4525 DNF
Re: Yast will nicht mehr
« Antwort #4 am: 27.September 2009, 21:26:47 »
ich habe alle Yast-Pakete neu installiert und bekomme die Fehlermeldung immer noch.

Hi,
welche Pakete hast du neu installiert? Nur YaST oder auch die qt-Pakete
Gruß Tuxus

Und aus dem Chaos sprach eine Stimme zu mir:
"Lächle und sei froh, es könnte schlimmer kommen!"
Und ich lächelte und war froh, und es kam schlimmer!

Offline hexe

  • Foren-Gott
  • *******
  • Beiträge: 1631
  • Geschlecht: Weiblich
  • Betriebssystem: Open Suse 11.2
  • Grafische Oberfläche: KDE 4.2.4
Re: Yast will nicht mehr
« Antwort #5 am: 28.September 2009, 10:54:46 »
Welche SuseVersion hast du?

gruss Hexe
gruss Hexe



Linux - damit der Ausnahmefehler nicht zur Regel wird

tomm.fa

  • Gast
Re: Yast will nicht mehr
« Antwort #6 am: 30.September 2009, 11:52:13 »
Zeige doch einfach mal die Ergebnisse von folgenden Befehlen:
cat /etc/SuSE-release(Auch wenn es gut zu sehen ist, zwischen cat und /etc ist ein Leerzeichen.)
rpm -qa|egrep -i 'yast|qt'zypper lr -d
« Letzte Änderung: 30.September 2009, 11:53:57 von tomm.fa »

Offline goldenstar

  • Foren-Aktivist
  • **
  • Beiträge: 11
Re: Yast will nicht mehr
« Antwort #7 am: 10.Oktober 2009, 13:25:46 »
Hi
cat /etc/SuSE-release ergibt:
openSUSE 11.0 (i586)
VERSION = 11.0

rpm -qa|egrep -i 'yast|qt'   ergibt:
libdbus-1-qt3-0-0.8.1-24.1
libQtWebKit4-4.4.3-15.1
yast2-core-2.16.51-6.1
yast2-gtk-2.16.15-0.1
yast2-update-2.16.10-4.1
autoyast2-installation-2.16.19-0.1
yast2-schema-2.15.0-227.1
libqt4-x11-4.4.3-28.1
yast2-storage-lib-2.16.26-0.1
yast2-ncurses-2.16.27-8.1
yast2-firewall-2.16.2-25.1
yast2-fingerprint-reader-2.16.8-6.1
yast2-ldap-client-2.16.16-6.1
yast2-dirinstall-2.16.3-20.1
yast2-qt-2.16.53-5.1
gambas2-gb-qt-ext-2.12-3.4
libqt4-4.5.90+4.6.0.20090521-1.1
yast2-sysconfig-2.16.0-28.1
yast2-country-2.16.26-6.1
yast2-profile-manager-2.16.1-27.1
gambas2-gb-qt-kde-html-2.12-3.4
yast2-trans-de-2.16.17-0.1
yast2-ncurses-pkg-2.16.14-0.4
yast2-scanner-2.16.10-13.1
yast2-repair-2.16.12-4.1
pinentry-qt-0.7.5-5.1
dbus-1-qt3-0.62-179.1
yast2-theme-openSUSE-2.16.38-2.1
yast2-2.16.71-6.1
yast2-irda-2.16.1-25.1
yast2-mouse-2.16.1-26.1
yast2-nis-client-2.16.3-6.1
yast2-installation-2.16.50-3.1
yast2-network-2.16.48-3.1
yast2-libyui-devel-2.16.48-3.1
yast2-qt-devel-2.16.53-5.1
yast2-devtools-2.16.8-19.1
yast2-control-center-gnome-2.13.3-11.1
yast2-xml-2.16.1-14.1
yast2-perl-bindings-2.16.7-14.1
yast2-pam-2.16.2-17.1
yast2-storage-2.16.26-0.1
yast2-security-2.16.1-16.1
yast2-samba-client-2.16.9-3.1
yast2-metapackage-handler-0.8.5-16.1
yast2-samba-server-2.16.3-15.1
yast2-backup-2.16.7-0.1
yast2-theme-openSUSE-Crystal-2.16.38-2.1
yast2-control-center-qt-2.16.2-11.1
yast2-add-on-creator-2.16.14-0.1
gambas2-gb-qt-kde-2.12-3.4
libqt4-qt3support-4.5.90+4.6.0.20090521-1.1
yast2-qt-pkg-2.16.49-0.1
qtcurve-gtk2-0.59.3-5.1
qtcurve-kde-0.59.1-13.1
yast2-ntp-client-2.16.9-11.1
yast2-sound-2.16.11-6.1
yast2-kerberos-client-2.16.11-9.1
yast2-restore-2.16.2-26.1
yast2-sudo-2.16.1-27.1
libqtpod0-0.4.2-8.1
yast2-transfer-2.16.1-76.1
yast2-iscsi-client-2.16.14-6.1
yast2-ruby-bindings-0.3.2-11.1
licq-qt4-gui-1.3.6-0.pm.1
libqt4-sql-4.5.90+4.6.0.20090521-1.1
libpoppler-qt2-0.10.6-1.10
yast2-pkg-bindings-2.16.42-0.2
yast2-control-center-2.16.2-11.1
yast2-packager-2.16.53-3.1
yast2-inetd-2.16.0-27.1
yast2-phone-services-2.16.0-27.1
yast2-country-data-2.16.26-6.1
yast2-support-2.16.1-6.1
yast2-vm-2.16.5-7.1
yast2-bootloader-2.16.20-0.1
yast2-mail-plugins-2.16.6-2.1
yast2-online-update-frontend-2.16.15-6.1
yast2-product-creator-2.16.19-3.1
qt3-3.3.8b-98.1
libqt4-sql-mysql-4.5.90+4.6.0.20090521-3.1
vlc-qt-1.0.1-0.pm.0
yast2-ycp-ui-bindings-2.16.47-5.1
yast2-runlevel-2.16.5-15.1
yast2-tv-2.16.6-7.1
yast2-registration-2.16.7-4.1
yast2-mail-2.16.6-2.1
gambas2-gb-qt-2.12-3.4
yast2-x11-2.15.12-15.1
yast2-ldap-2.16.0-52.1
yast2-tune-2.16.2-2.1
yast2-printer-2.16.32-3.1
python-qt-3.17.4-49.1
yast2-libyui-2.16.48-3.1
yast2-hardware-detection-2.16.1-49.1
yast2-apparmor-2.16.4-4.1
yast2-drbd-2.13.1-158.1
yast2-ca-management-2.16.7-9.1
yast2-trans-stats-2.15.0-87.1
yast2-slp-2.16.0-25.1
yast2-nfs-client-2.16.1-26.1
yast2-update-FACTORY-2.16.10-4.1
yast2-add-on-2.16.8-6.1
yast2-users-2.16.33-6.1
yast2-autofs-2.15.4-21.1
yast2-online-update-2.16.15-6.1
yast2-core-devel-2.16.51-6.1
yast2-casa-ats-1.7.1534-2.1


zypper lr -d ergibt:

#  | Alias                               | Name                              | Enabled | Refresh | Priority | Type   | URI     
---+-------------------------------------+-----------------------------------+---------+---------+----------+--------+---------------------------------------------------------------------------------------------------
1  | openSUSE_11.0_KDE_42                | openSUSE_11.0_KDE_42              | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/KDE4:/Community/openSUSE_11.0_KDE_42/
2  | non-oss                             | non-oss                           | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.0/repo/non-oss/
3  | openSUSE_11.0_5                     | openSUSE_11.0                     | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/KDE4:/STABLE:/Desktop/openSUSE_11.0/
4  | openSUSE_11.0_2                     | openSUSE_11.0                     | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/gbvalor/openSUSE_11.0/
5  | gwdg                                | gwdg                              | Yes     | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/misc/packman/suse/11.0/
6  | repo-debug                          | openSUSE-11.0-Debug               | Yes     | Yes     |  120     | yast2  | http://download.opensuse.org/distribution/11.0/repo/debug/
7  | openSUSE_11.0_1                     | openSUSE_11.0                     | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/hamradio/openSUSE_11.0/
8  | emulatoren                          | emulatoren                        | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/Emulators/openSUSE_11.0/
9  | openSUSE_11.0_KDE_42_1              | openSUSE_11.0_KDE_42              | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/KDE4:/Playground/openSUSE_11.0_KDE_42/
10 | openSUSE_11.0_7                     | openSUSE_11.0                     | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/42/openSUSE_11.0/
11 | wine                                | wine                              | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/Emulators:/Wine/openSUSE_11.0/
12 | openSUSE_11.0_KDE4_STABLE_Desktop_1 | openSUSE_11.0_KDE4_STABLE_Desktop | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/KDE4:/Playground/openSUSE_11.0_KDE4_STABLE_Desktop/
13 | repo-oss                            | openSUSE-11.0-Oss                 | Yes     | Yes     |  120     | yast2  | http://download.opensuse.org/distribution/11.0/repo/oss/
14 | openSUSE_11.0                       | openSUSE_11.0                     | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home%3a/anubisg1/openSUSE_11.0/
15 | openSUSE_11.0_4                     | openSUSE_11.0                     | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/Community/openSUSE_11.0/
16 | kde                                 | kde                               | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/KDE3/openSUSE_11.0/
17 | openSUSE-DVD 11.0                   | openSUSE-DVD 11.0                 | No      | No      |   99     | yast2  | cd:///?devices=/dev/sr0
18 | mozilla                             | mozilla                           | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/mozilla/openSUSE_11.0/
19 | openSUSE_11.0_3                     | openSUSE_11.0                     | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/Java:/packages/openSUSE_11.0/
20 | openSUSE_11.0_6                     | openSUSE_11.0                     | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/Qt46/openSUSE_11.0/
21 | openSUSE_11.0_KDE4_STABLE_Desktop   | openSUSE_11.0_KDE4_STABLE_Desktop | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/KDE4:/Community/openSUSE_11.0_KDE4_STABLE_Desktop/
22 | openSUSE-11.0-Updates               | openSUSE-11.0-Updates             | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/11.0/
23 | repo-non-oss                        | openSUSE-11.0-Non-Oss             | Yes     | Yes     |  120     | yast2  | http://download.opensuse.org/distribution/11.0/repo/non-oss/
24 | Google                              | Google                            | Yes     | Yes     |   99     | rpm-md | http://dl.google.com/linux/rpm/stable/i386



flotte Gr??e Goldenstar

Edit: Ich habe den Beitrag mal eben dahingehend ge?ndert das ich deine Ausgabe als Code hier eingef?gt habe,
ich m?chte dich der ?bersichtlichkeit wegen bitten dies k?nftig auch so zu machen bei so langen Ausgaben.
« Letzte Änderung: 10.Oktober 2009, 13:31:02 von Zickenbaendiger »

Offline DancingAntS

  • Foren-König
  • *****
  • Beiträge: 511
  • Geschlecht: Männlich
  • Betriebssystem: OpenSUSE 11.3
  • Grafische Oberfläche: KDE 4.6
  • Hardware: AthlonXP2600+, ATI Radeon9600Pro
Re: Yast will nicht mehr
« Antwort #8 am: 10.Oktober 2009, 18:43:56 »
Hi goldenstar,  :)

L?sche doch mal das Qt4.6-Repository, stattdessen bindest Du das Qt4.4-Repository ein. Gib diesem Repository eine h?here Priorit?t (also niedrigere Zahl) als den anderen (speziell hier OSS und Update sind gemeint).
Dann starte ein Update der Qt-Pakete mit der Option unbedingt aktualisieren. Am besten noch gleichzeitig ein allgemeines systemweites Update.

Wenn Du schon beim ?ndern der Repository-Eintr?ge bist kannst Du ja auch gleich doppelt vorhandene Quellen l?schen ( z.B. NON-OSS). Ebenfalls kannst Du die Quellen f?r eine KDE4-Version deaktivieren oder l?schen (KDE4.2 oder KDE4.1). Die Google-Quelle d?rfte doch auch ?berfl?ssig sein.

Die ?nderungen kannst Du ?ber die Konsole machen. Dort auf den Root-Account wechseln und entweder mit zypper oder mit yast machen. Eine gro?es Terminalfenster speziell bei yast ist hilfreich.

Noch ein kleiner Ratschlag: Wenn Du die Priorisierung der Quellen besser nutzt kannst Du damit einen besseren Workaround bei der Paketverwaltung erreichen.

Gru? DancingAntS



tomm.fa

  • Gast
Re: Yast will nicht mehr
« Antwort #9 am: 11.Oktober 2009, 03:34:07 »
Die Liste der Repos geh?rt wirklich mal gr?ndlich ausgemistet, kein Wunder wenn irgendwann etwas nicht mehr funktioniert. F?hre mal als su ein: zypper in yast2-qt aus. Sp?ter kommt noch eine Anweisung zum Gro?reinemachen.  ;)

Offline goldenstar

  • Foren-Aktivist
  • **
  • Beiträge: 11
Re: Yast will nicht mehr
« Antwort #10 am: 18.Oktober 2009, 16:44:49 »
Hi,
Habe die qt 4.4 eingef?gt und die anderen gel?scht. Das Problem besteht aber immer noch.

Ein "zypper in yast2-qt" ergibt:

Reading installed packages...
'yast2-qt' is already installed.
Nothing to do.

flotte Gr??e Goldenstar

Offline DancingAntS

  • Foren-König
  • *****
  • Beiträge: 511
  • Geschlecht: Männlich
  • Betriebssystem: OpenSUSE 11.3
  • Grafische Oberfläche: KDE 4.6
  • Hardware: AthlonXP2600+, ATI Radeon9600Pro
Re: Yast will nicht mehr
« Antwort #11 am: 29.Oktober 2009, 15:24:19 »
Hi goldenstar,

besteht Dein Problem noch?

Zitat
Habe die qt 4.4 eingef?gt und die anderen gel?scht. Das Problem besteht aber immer noch.
Hattest Du auch mal ein systemweites Update gemacht? Also entweder per zypper dupoder bei yast Listenupdate ?ber Installationsquellen→@System? (finde ich schneller als ?ber Paketgruppen→Alle Pakete)
Deine Fehlermeldung  YaST got signal 6 at YCP file Wizard.ycp:688 sagte n?mlich aus das es bei der Ermittlung der Suse-Release ausgestiegen ist (Die Quelltexte der Yast-Module findet man unter /usr/share/YaST2/modules/ ) Also beim Abgleich mit der Umgebung. Es muss also nicht unbedingt an einem fehlerhaften Yast-Package liegen.

Gru? DancingAntS