Autor Thema: SuSE 11.1 - sehr langsame graf. Oberfl?che  (Gelesen 7321 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Palamedes

  • Gast
SuSE 11.1 - sehr langsame graf. Oberfl?che
« am: 18.März 2009, 22:47:13 »
Wie schon an anderer Stelle berichtet, l?uft SUSE auf meinem neuen Laptop extrem langsam. Ich schreibe schneller als der Bildschirm anzeigt; beim Scrollen werden die Rahmen aufgerissen; der Bildaufbau dauerd sehr lange.
Installiert habe ich SUSE Linux 11.1 (64 Bit)
Hier kurz die Daten:
Dell Vostro 1000, 2 GB Ram
Prozessor (CPU):   AMD Athlon(tm) 64 X2 Dual-Core Processor TK-57
  Geschwindigkeit:  1,900.00 MHz
  Kerne:  2
Graphikkarte:
Hersteller:   DRI R300 Project
  Modell:   Mesa DRI R300 20060815 NO-TCL
  Treiber:   1.3 Mesa 7.2
Warum das so ist, ist nicht ersichtlich: ausweislich der System?berwachung ist der Rechner chronisch unterfordert.

Edit vom Moderator → Linuxsusefan
Ich war mal so frei und habe den Beitrag in die Rubrik geschoben wo es vom Thema auch hinpasst. Au?erdem habe ich den auch den ?Titel des Thema' s? an den Inhalt des eigentlichen Thema' s ge?ndert. Ich habe das der besseren ?bersicht wegen gemacht damit andere User / Querleser bei evntl ?hnlichen Problemen oder der Interesse haber dies auch wieder finden k?nnen. 
« Letzte Änderung: 19.März 2009, 11:16:56 von linuxsusefan »

linuxsusefan

  • Gast
Re: Linux sehr langsam
« Antwort #1 am: 19.März 2009, 09:09:45 »
Hallo,

Das d?rfte daran liegen das hier nicht der Treiber passend zur vorhandenen Grafikkarte l?uft. Deshalb d?rfte es solche " Darstellungsfehler " wie Du die Beschrieben hast geben. Hier sollte wir genau wissen was f?r eine Grafikkarte da drin ist & welcher Kernel werkelt. Dazu ?ffnest Du bitte eine Konsole Postest bitte folgende Konsolen-Ausgaben:

hwinfo --gfxcard
zeigt Infos ?ber die Grafikkarte an, und dann

uname -r
zeigt Infos ?ber den Installierten Kernel an. Setze die Konsolen-Ausgaben bitte jeweils in eigene in " code-tags " damit das ?bersichtlich bleibt.

Palamedes

  • Gast
Re: Linux sehr langsam
« Antwort #2 am: 19.März 2009, 22:52:16 »

hwinfo --gfxcard
Da steht
hwinfo --gfxcard
28: PCI 105.0: 0300 VGA compatible controller (VGA)
  [Created at pci.318]
  UDI: /org/freedesktop/Hal/devices/pci_1002_5974
  Unique ID: ul7N.2cFTQ9VAV_2
  Parent ID: vSkL.dQFUNbiC_g9
  SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:05.0
  SysFS BusID: 0000:01:05.0
  Hardware Class: graphics card
  Model: "ATI Radeon XPRESS 200 5974 (PCIE)"
  Vendor: pci 0x1002 "ATI Technologies Inc"
  Device: pci 0x5974 "Radeon XPRESS 200 5974 (PCIE)"
  SubVendor: pci 0x1028 "Dell"
  SubDevice: pci 0x022a
  Memory Range: 0xc8000000-0xcfffffff (rw,prefetchable)
  I/O Ports: 0x9000-0x9fff (rw)
  Memory Range: 0xc0100000-0xc010ffff (rw,non-prefetchable)
  Memory Range: 0xc0120000-0xc013ffff (ro,prefetchable,disabled)
  IRQ: 17 (24644 events)
  I/O Ports: 0x3c0-0x3df (rw)
  Module Alias: "pci:v00001002d00005974sv00001028sd0000022Abc03sc00i00"
  Driver Info #0:
    XFree86 v4 Server Module: radeon
  Driver Info #1:
    XFree86 v4 Server Module: fglrx
    3D Support: yes
    Extensions: dri
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #9 (PCI bridge)

Primary display adapter: #28


Zur zweiten Frage (Kernel):

uname -r
Dort lautet die Ausgabe:
2.6.27.19-3.2-default

linuxsusefan

  • Gast
Re: SuSE 11.1 - sehr langsame graf. Oberfl?che
« Antwort #3 am: 20.März 2009, 09:40:36 »
Hallo,

das sieht soch schonmal ganz gut aus. Hier sollte sich das " Problem " mit einem ATI / AMD -Treiber l?sen lassen. Dazu muss eine Repo-Quelle eingebunden und die ATI / AMD Treiberpakete installiert werden.

Wie man Repo-Quellen einbindet findest Du u.a. auch hier im → Wiki-L?sungscenter beschrieben.

Wie man dann welche ATI / AMD - Treiber installiert & Konfiguriert, findet man dort → OpenSuSE - ATI -Treiber Installieren beschrieben.

Bitte auf Genauigkeit bei den ?Kernel- /  -Treiber - Paketen? achten! Die m?ssen in Version genau ?bereinstimmen, sonst klappt das nicht.

Offline Zuzia

  • Foren-Legende
  • ****
  • Beiträge: 334
  • Geschlecht: Männlich
  • Betriebssystem: SuSE 11.2, Linux 2.6.31.12-0.1.1-default i686
  • Grafische Oberfläche: KDE 4.4.1 rel.225
  • Hardware: Athlon 2000+ , ATI Radeon 9500pro, Drucker Canon i865
Re: SuSE 11.1 - sehr langsame graf. Oberfl?che
« Antwort #4 am: 20.März 2009, 11:50:37 »
Hi, ich habe festgestellt, dass meine ATI Graka mit dem Compiz-Paket auch langsam arbeitet. Versuche mal das Compiz und die Arbeitsfl?chen Effekte (in Systemeinstellungen -> Arbeitsfl?che) zu deaktivieren.
?brigens: Der neue ATI Treiber von der Repo ATI unterst?tzt ?ltere Modelle (wie meine Radeon 9500pro) nicht mehr - deswegen auf MESA-Treiber ausgewichen.
Gru? Z.
L?sst man einer Sache nur genug Zeit, so erledigt sich jedes Problem

linuxsusefan

  • Gast
Re: SuSE 11.1 - sehr langsame graf. Oberfl?che
« Antwort #5 am: 20.März 2009, 12:32:05 »
Hi Zuzia,

er hat aber eine andere Grakka und da ist' s mit Treiber etc doch etwas anderes.

Palamedes

  • Gast
Re: SuSE 11.1 - sehr langsame graf. Oberfl?che
« Antwort #6 am: 22.März 2009, 15:48:03 »
Ich habe es gemacht. Ich will das Ergebnis nicht vorenthalten: Schwarzer Bildschirm. Und zwar auch beim booten "failsafe". Ich zerspringe vor Gl?ck.
Was tun?

Palamedes

  • Gast
Re: SuSE 11.1 - sehr langsame graf. Oberfl?che
« Antwort #7 am: 24.März 2009, 18:33:13 »
Ich will euch den weiteren Verlauf nicht vorenthalten:
Die EasyLinux-Starter-Kit-DVD bietet diese Treiber gleich mit. Als Repository installiert, dann die entsprechenden Treiber drauf. 20 Minuten Arbeit f?r die Festplatte.
Neustart: schwarzer Bildschirm.
Auf den Ausknopf. Rechner f?hrt herunter. Neustart Failsafe: Schwarzer Bildschirm.
Wieder Neustart. Windows und die Meldung ins Forum.
Vielleicht die Reparatur-Routine. Hier meine Warnung an alle SUSE-Nutzer: Niemals, unter keinen Umst?nden, benutzen!!!
Die Routine stellt fest, dass das System in Ordnung sei. Linux- und Windows-Partitionen werden erkannt. Da die Meldung: GRUB-Konfigurationsdatei enth?lt einen Fehler: Reparieren? Aber ja (der d?mlichste Fehler, der mir passieren konnte).
Dies l?uft durch und zeigt Wirkung: beim n?chsten Neustart zeigt der Bootloader nur noch zwei Eintr?ge: SUSE-Linux und SUSE Linux (failsafe). Diese wiederum zeigen keine Ver?nderung: der Bildschirm schimmert im edlen Schwarz der intellektuellen Republik.
Also noch einmal durch die Routine: vielleicht kriegt man ja die Windows-Datei wieder herein.
Um es gleich zu sagen: kriegt man nicht (jedenfalls ich nicht). Nach zwei Durchl?ufen, bei denen ich jedes Mal den Empfehlungen des Systems gefolgt bin, ist nicht einmal mehr SUSE bootbar: „Error, no Operating System“.
Okay, es gibt ja die Neuinstallation. Das Homeverzeichnis hatte ich anderweitig gesichert und noch nicht ver?ndert bzw. konnte die drohenden wenigen Verluste verschmerzen. An dieser Stelle ein Wunschzettel an das KDE-Team: beim Versuch, die Mails auf einem Filesystem zu speichern, das die Rechtevergabe nicht unterst?tzt (FAT), erwarte ich keine Fehlermeldung („kann nicht geschrieben werden“), sondern einen Dialog, der mich fragt, ob es dann eben ohne gehen soll mit der Folge, dass dann danach jeder alles darf.
Hier zeigt sich jetzt eine Nebenwirkung des neuen Systems, eine eigene Home-Partition anzulegen: dort befinden sich offensichtlich auch Bootloader-Dateien, die dadurch auch nicht ver?ndert werden, sodass es auch nach der Neuinstallation hei?t: NO OPERATING SYSTEM.
Nach der bereits beschriebenen Pleite der Xfce-Version jetzt ein weiterer Kratzer im SUSE-Lack: eine Reparatur-Routine, die aus einem fehlerhaften ein nicht bootbares System macht, zeigt Raum f?r Verbesserungen auf. 
Gleichzeitig ist die Idee, das Home-Verzeichnis auf eine gesonderte Partition zu legen, sicherlich zu begr??en, erspart sie doch den aufw?ndigen (und gern ins Chaos f?hrenden) Weg des Neuaufbaus des ganzen Computers. Dass dies dann aber dazu f?hrt, dass ein vermurkster Bootloader selbst eine Neuinstallation unver?ndert ?bersteht, ist mehr als ein Sch?nheitsfehler.
Wie jetzt weiter?
Der einfachste Weg (s?mtliche Rechner bei e-Bay eingestellt und Macs gekauft) erheischt erh?hten Kl?rungsbedarf der kurz- und mittelfristigen Finanzplanung.
Ich entschlie?e ich mich zur n?chsteinfacheren Methode: Brachialgewalt, i.e. Festplatte l?schen, Windows neu drauf, dann Linux. Diese Methode hat gegen?ber sonstigen Reparaturversuchen vier Vorteile: 1. Zuverl?ssiger (es besteht keine Gefahr, dass irgendwo etwas ?bersehen wird), 2. in der Regel schneller (aus dem gleichen Grunde – es entfallen weitere Reparaturrunden), 3. bequemer (das meiste macht der Rechner allein) und daher 4. dem Wohlbefinden zutr?glicher.
Der geplante Verlauf:
1. Im Internet nachsehen, wie es mit ATI-Karten und den verschiedenen Distributionen aussieht.
2. Knoppix downloaden und auf CD brennen.
3. Live-Ssystem starten und der USB-Stick neu formatieren.
4. Home-Verzeichnist sichern und Knoppix herunterfahren.
5. Windows installieren.
6. Linux installieren
7. Pers?nliche Daten aufspielen.
Vorsichtshalber wird der Schreibtisch zudem mit Aufgaben gef?llt, die bei schlechter Laune besser von der Hand gehen. Dies sollte sich als Zeichen weiser Voraussicht erweisen.
Zur milit?rischen Pr?zision der Planung gesellt sich eine alte milit?rische Erfahrung: ?u?erste zeitliche Grenze jeder Planung ist die erste Feindber?hrung. Schon Stufe 1 (die Suche nach der Unterst?tzung der ATI-Karte) ger?t zum Geduldsspiel. Ob – und wenn ja, wie – die hier verbaute unterst?tzt wird, ist nicht abschlie?end zu kl?ren. Insbesondere fehlt es an Hinweisen, was bis zur Installation des entsprechenden Treibers geschehen wird. 
Die Stufen 2 und 3 k?nnt ihr unter "Installationsberichte" nachlesen.
Auf der Suche nach Schokoladen-Vorr?ten (ich brauche Trost, und die Frau ist nicht da) f?llt mir die Kubuntu-CD (8.04) in die H?nde. Eine kleine Gehirnzelle hat ihre gro?e Stunde: Ubuntu l?sst sich auch als Live-System installieren. Sofort zum Rechner.
Neues Spiel, neuer Fehlschlag. Hier baut sich gleich gar nichts auf. Bisweilen zucken ein paar Linien ?ber den Schirm, das wars.
Beim Mittagessen analysiert die Dame meines Herzens meine Ank?ndigung, bei Linux zu bleiben: „Es muss Liebe sein. Du bist schlie?lich auch der Einzige, bei dem ich eine solche Low-Perfomance durchgehen lasse!“
W?hrend die Formulierung im Indikativ noch an mir nagt, ?berlege ich mir L?sungsm?glichkeiten.
Zun?chst einmal TinyMe - hat ja auch anderswo geklappt.
Aber nicht hier. Schon das Laden des Systems dauert verd?chtig lange; immer wieder unheilschwangeres Knacken aus dem Laufwerk. Offensichtlich muss man kr?ftig suchen. Am Ende verschwindet der blaue Tropfen und macht einem schwarzen Bildschirm Platz.


Offline bloedie

  • Foren-Gott
  • *******
  • Beiträge: 5047
  • Geschlecht: Männlich
  • Ich bin immer m?de und Urlaubsreif!!!
    • Linux Hardwaredatenbank
  • Betriebssystem: Gentoo
  • Grafische Oberfläche: KDE SC 4.5.3
  • Hardware: Intel Quad Core i5-2500K, NVIDIA GeForce 8600 GT Grafikkarte, 4x500 GB S-ATA, S-ATA DVD-Brenner, Syncmaster 226BW TFT-Monitor, 8GB RAM
Re: SuSE 11.1 - sehr langsame graf. Oberfl?che
« Antwort #8 am: 24.März 2009, 21:12:39 »
Hi.

Wenn man liest was Du so alles anstellst, w?rde ich Dir mal unseren
Telefonsupport anbieten. Vielleicht bekommen wir damit eine Distri
auf Deinem Laptop zum laufen.

Cu.
Bloedie
Meine Rechtschreibfehler sind gewollt und wer sie findet darf sie gerne behalten.
http://www.gentoofreunde.org

Palamedes

  • Gast
Re: SuSE 11.1 - sehr langsame graf. Oberfl?che
« Antwort #9 am: 25.März 2009, 12:03:54 »
Nicht mehr n?tig:
Ich habe schlie?lich oben beschriebenen Plan ab Schritt 5 ausgef?hrt: die – ansonsten heftig beklagte – Eigenschaft von Windows, Linux-Partitionen nicht zu erkennen bzw. r?cksichtslos zu ?berschreiben, hat sich hier als Segen erwiesen. Dass dies ohne gr??eren Schaden m?glich war, beruht aber – dies sei noch einmal klargestellt – auf dem zuf?lligen Umstand, dass sich auf der Festplatte (noch) keine wichtigen Daten, deren Verlust L?cken gerissen h?tte, befanden. Kurz: w?re mir das in ein paar Monaten passiert, w?re ich jetzt voraussichtlich erheblich zorniger.
Ich nutze dies zu einem Fazit: gelungene Werbung f?r Linux war das nicht.
Bei allem Verst?ndnis f?r die Probleme, die der hohe „Innovations“-Druck mit sich bringt: das geht nicht. Das aufgrund von Inkompatibilit?ten ?berhaupt nichts mehr geht, insbesondere nicht einmal ein verschwommener Bildschirm erscheint, glaubte ich seit meinem 386sx ?berwunden. Hier ist es an der Zeit, anstatt immer neue 3D-Gimmicks zu entwickeln, zumindest einen Notbetrieb sicherzustellen. Das dies m?glich ist, zeigt ja der Umstand, dass vor der Installierung des Treibers das ganze funktionierte. Ein schwarzer Bildschirm ist der GAU.
Noch schlimmer die Funktion der „Systemreparatur“: ein funktionierender Rechner verwandelt sich in unbrauchbaren Schrott, und zwar nicht durch irgendwelche exotischen Shell-Scripte, sondern mit – vom System selbst empfohlenen – Mauklicks. Eine solche Leistung ?bertrifft meine wildesten Tr?ume.
Dazu gesellt sich die Pleite der sogenannten "Rettungssysteme": kein Live-System war zur Aufnahme einer T?tigkeit zu bewegen.


Offline bloedie

  • Foren-Gott
  • *******
  • Beiträge: 5047
  • Geschlecht: Männlich
  • Ich bin immer m?de und Urlaubsreif!!!
    • Linux Hardwaredatenbank
  • Betriebssystem: Gentoo
  • Grafische Oberfläche: KDE SC 4.5.3
  • Hardware: Intel Quad Core i5-2500K, NVIDIA GeForce 8600 GT Grafikkarte, 4x500 GB S-ATA, S-ATA DVD-Brenner, Syncmaster 226BW TFT-Monitor, 8GB RAM
Re: SuSE 11.1 - sehr langsame graf. Oberfl?che
« Antwort #10 am: 25.März 2009, 12:18:51 »
Hi.

Ich verstehe ja Deinen Frust, aber k?nnte es vielleicht auch daran liegen
das DU bei der Installation irgendetwas falsch gemacht hast oder wichtige
Informationen einfach ?bersehen/?berlesen hast?

Linux neben Windows zu installieren sollte nun wirklich kein Problem sein,
anders herum schon eher.

Cu.
Bloedie
Meine Rechtschreibfehler sind gewollt und wer sie findet darf sie gerne behalten.
http://www.gentoofreunde.org

linuxsusefan

  • Gast
Re: SuSE 11.1 - sehr langsame graf. Oberfl?che
« Antwort #11 am: 25.März 2009, 12:26:22 »
@ Palamedes,

man oh man, was ist das f?r ein Unsinn....Sorry, aber was Du da verzapfst .....

Den Treiber einspielen reicht nicht, den muss man auch richtig konfigurieren ( so wie es auch auf der Anleitungs-Seite steht), dann geht das auch ( zumindest bei vielen anderen Usern auch ).
« Letzte Änderung: 25.März 2009, 12:28:24 von linuxsusefan »

Palamedes

  • Gast
Re: SuSE 11.1 - sehr langsame graf. Oberfl?che
« Antwort #12 am: 25.März 2009, 12:30:58 »
Es mag sein, dass ich etwas falsch gemacht habe. Es ist aber nicht ersichtlich, was: ich habe nur die Dinge getan, die das System selbst empfohlen hat.
Bei der Installation der ATI-Radeon-Treiber habe ich mich an die Vorgaben des Systems gehalten. Es wurde zudem eine Vielzahl von Programmen, Bibliotheken etc. mit installiert. Ich darf mich wohl darauf verlassen, dass entweder alle Abh?ngigkeiten erkannt werden und nicht irgendetwas vergessen wird oder - wenn das nicht m?glich ist - wenigstens gewarnt wird, dass noch etwas getan werden muss. Statt dessen einfach Yast zu beenden, weiterhin den Bildschirm anzuzeigen und sich erst beim Neustart zu verabschieden ist schlicht t?ckisch. An dieser Stelle wiederhole ich meinen Anspruch: schwarzer Bildschirm darf unter keinen Umst?nden passieren.
Meine Fehler bei der Systemrepapratur selbst sind mir schon klarer: 1. sie ?berhaupt verwandt zu haben und 2. ihren Empfehlungen gefolgt zu sein. H?tte ich das gelassen, w?re wenigstens noch Windows erreichbar gewesen.

linuxsusefan

  • Gast
Re: SuSE 11.1 - sehr langsame graf. Oberfl?che
« Antwort #13 am: 25.März 2009, 12:53:33 »
@ Palamdes,

mit verlaub das ist totaler Quatsch.

Wenn man Dir schon einen Link zu einer Seite mit einer Install-Anleitung bigt, so musst Du dir das alles auch richtig durchlesen. Eine Konfig. eines eingespielten Treibers bekommst Du soo in diesem zusammenhang nicht vom System empfohlen. Daf?r stand das aber auf der geposteten Seite beschrieben, genauso wie ein Link zur ATI / AMD Seite um zu schauen ob die Karte unterst?tzt wird.

Wer sich Linux-BS zulegt muss sich auch damit befassen und sich vom gedanken verabschieden ein Windows-Ersatz zu haben ( Was ich Bspw. im Wiki in " Der Start ins Linuxland " auch ausf?hrlichst erw?hne, man muss es nur mal lesen). Linux ist & bleibt was ganz & v?llig anderes und ist kein " Windows-Clon "! Zum Gl?ck nicht, das w?re ja noch sch?ner. Hier wird wieder sichtbar das manche User denken das Linux genauso ist wie Windows, das ist es nicht. Leute die das denken sind bei Windows vllt. besser aufgehoben.

Das bei SuSE 11.1zu beginn nicht alles grade war hat nichts mit dem ATI / AMD Treiber zu tun, das hatte andere Ursachen und die sind l?ngst beseitigt, au?erdem steuert ATI /AMD die Treiber bei und damit hat SuSE nix zu tun.  

Nix f?r ungut, aber ich f?r meinen Teil hab mein bestes versucht, deshalb klinke ich mich hier aus....By By
« Letzte Änderung: 25.März 2009, 12:57:13 von linuxsusefan »

Palamedes

  • Gast
Re: SuSE 11.1 - sehr langsame graf. Oberfl?che
« Antwort #14 am: 25.März 2009, 13:10:46 »
@linuxsusefan:

Auf solche Beitr?ge habe ich gewartet:
1. Ich halte daran fest, dass ich Warnungen erwarten darf. Und vor allem darf ich erwarten, dass Yast mir mitteilt, dass es mit der Installation des Treibers nicht getan ist. Dies gilt umso mehr, als auch der zitierten Seite nicht entnommen werden kann, dass
a. im Falle ausbleibender/fehlerhafter Konfiguration ein Totalausfall droht (gerechnet h?tte ich eher damit, dass dann eben das geschilderte Problem nicht beseitigt wird) und
b. diese nicht mehr nachgeholt werden kann.
Ich bin hier schlicht ins offene Messer gelaufen. An dieser Stelle sei erinnert, dass nicht nur Leopard, sondern sogar das von Dir so verachtete Windows in der Lage ist, die Konfiguration durchzuf?hren, ohne den User zu bel?stigen und vor allem nicht gleich einen Totalausfall hinlegt.
2. Das Versagen der Systemreparatur wie auch der verschiedenen Live-Systeme kannst Du mir nicht anlasten.
3. Mein Hilferuf wurde am 22.03. eingestellt. Vor diesem Hintergrund kommen Deine - wenig hilfreichen, aber daf?r arroganten und gro?m?uligen - Beitr?ge reichlich sp?t. Mit Beschimpfungen der ach so doofen User, die zudem den Rechner als Gebrauchsgegenstand einstufen und sich damit so wenig wie m?glich besch?ftigen wollen, tust Deiner Sache einen B?rendienst.